Limited functionality of Support Tools
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Feb 14, 2023 - 10:59 EST
Update
We are still working on resolving this issue. More information will follow soon.
Posted Feb 14, 2023 - 05:56 EST
Update
We are still working on resolving the technical issue.
Posted Feb 14, 2023 - 03:59 EST
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted Feb 14, 2023 - 01:39 EST
This incident affected: Customer Service (Support Tool).