Support Hotline cannot be reached
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted 4 months ago. Jun 19, 2019 - 02:53 EDT
Identified
An outage with one of our main offices are causing problems with our Technical Support line. You may experience a greater hold time than usual. We apologize for any inconvenience during these brief technical difficulties and appreciate your patience and understanding. We will continue to post updates as we make progress on these issues.

Please reach our customer care unit via e-mail at support@1and1.com
Posted 4 months ago. Jun 19, 2019 - 02:31 EDT
This incident affected: Customer Service (Customer Hotline).