Technical issues with our main page www.ionos.com
Incident Report for ionos.com
Resolved
The systems are stable and all services are functioning normally again.
Posted May 25, 2021 - 04:32 EDT
Identified
Currently, some customers are not able to access www.ionos.com through Mozilla Firefox browser. We are currently working on resolving the technical disruption. We will have an update for you shortly.
Posted May 25, 2021 - 02:35 EDT
This incident affected: Contract Management (Order Page).