The systems are stable and services are functioning normally again.
Posted Oct 20, 2023 - 04:57 EDT
Identified
A technical issue in one of our main offices is impacting our support line. You may experience call disconnections unexpectedly.
Additionally, our Customer Service Team may not be able to answer all questions related to your account. We apologize for any inconvenience this may cause you.
Posted Oct 20, 2023 - 04:39 EDT
This incident affected: Customer Service (Customer Hotline, Support Tool).