Incident Report for Customer Service Support Tool
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Oct 05, 2020 - 05:32 EDT
Identified
Due to a technical issue with our Support Tools, our Customer Service Team are not able to answer all questions related to your account.
Posted Oct 05, 2020 - 05:26 EDT
This incident affected: Customer Service (Support Tool).