Greater hold time in our Hotline
Incident Report for ionos.com
Resolved
This incident has been resolved.
Posted 18 days ago. Mar 03, 2019 - 03:22 EST
Identified
Due to a techncial issue with our Support Tools, our Customer Service is not be able to answer all questions related to your account.
Posted 18 days ago. Mar 03, 2019 - 02:09 EST
This incident affected: Customer Service (Support Tool).