Placing orders currently not possible
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Mar 11, 2020 - 11:39 EDT
Identified
We are exeriencing technical issues with placing orders on our Main Page https://www.ionos.com/.
Posted Mar 11, 2020 - 11:22 EDT
This incident affected: Contract Management (Order Page).