Technical issues in our email systems

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted Aug 05, 2025 - 06:15 EDT

Identified

Some customers may be experiencing issues receiving E-mails.
Posted Aug 05, 2025 - 05:37 EDT
This incident affected: Email (Receiving Emails).