Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted 2 months ago. Jul 09, 2019 - 04:58 EDT
Identified
We are experiencing an issue with our Contract Tool. In urgent cases please contact Customer Care via 1-877-300-8316 to finalize the cancellation.
Posted 2 months ago. Jul 09, 2019 - 03:37 EDT
This incident affected: Contract Management (Cancellation Service).