Limited functionality of Support Tools

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted May 05, 2026 - 06:14 EDT

Identified

Due to a technical issue with our Support Tools, queries are processed late and some of the actions you request from our agents may not be performed at that time. Additionally, our Customer Service is not able to answer all questions related to your account.
Posted May 05, 2026 - 05:59 EDT
This incident affected: Customer Service (Support Tool).