Incident Report for ionos.com
Incident Report for ionos.com
Resolved
The issue has been resolved. We apologize for the inconvenience caused and thank you for your patience.
Posted Oct 16, 2020 - 23:29 EDT
Update
Some customers may be experiencing issues accessing IONOS services and websites where the internet provider is using Telia as a transit.
Posted Oct 16, 2020 - 20:22 EDT
Identified
We are experiencing technical issues with our website ionos.com
Posted Oct 16, 2020 - 19:06 EDT
This incident affected: Contract Management (Order Page).