Incident Report for Email & Office

Incident Report for ionos.com

Resolved

The issue has been resolved. Our apologies for the inconvenience caused.
Posted Jan 09, 2025 - 17:28 EST

Identified

Access to E-Mail & Office in the Control Panel may be temporarily restricted.
Posted Jan 09, 2025 - 17:15 EST
This incident affected: IONOS (IONOS Control Panel).