Sending and receiving e-mails is currently not possible
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Feb 17, 2021 - 18:04 EST
Identified
Some customers are experiencing issues when sending and receiving E-mails.
Posted Feb 17, 2021 - 16:56 EST
This incident affected: Email (Webmail).