We have successfully minimized the disruption and are working to completely resolve it as soon as possible.
Posted Jan 28, 2026 - 19:14 EST
Update
We are still working on resolving this issue. More information will follow soon.
Posted Jan 28, 2026 - 18:58 EST
Identified
We are currently experiencing a network issue affecting a group of servers. This may result in errors for customers trying to connect to their servers. Our engineers are prioritizing this issue and are working to resolve it as quickly as possible.
Posted Jan 28, 2026 - 18:42 EST
This incident affected: Server & Cloud (Dedicated Server, Cloud Server, VPS).