Disruption in logging into the Microsoft Exchange Portal
Incident Report for ionos.com
Resolved
This issue is resolved.
Posted Nov 13, 2019 - 04:50 EST
Identified
Currently, some customers may not be able to log into the Microsoft Exchange Portal.
Posted Nov 13, 2019 - 03:30 EST
This incident affected: Email & Office (Microsoft Exchange).