Technical issues in our email systems

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted Oct 12, 2023 - 12:10 EDT

Monitoring

We have eliminated the disruption for almost everyone affected. We apologize to customers who were affected by this disruption. We are working to ensure that similar issues do not occur in the future.
Posted Oct 12, 2023 - 11:33 EDT

Update

We have successfully minimized the disruption and are working to completely resolve it as soon as possible.
Posted Oct 12, 2023 - 10:19 EDT

Identified

Some emails sent to Microsoft-hosted email addresses may be rejected due to Microsoft blocking some of our IP addresses.

We are in contact with Microsoft to request de-listing.

Please accept our apologies for any inconvenience you may be experiencing.
Posted Oct 11, 2023 - 13:15 EDT
This incident affected: Email (Sending Emails).