Unable to view invoices in the Control Panel

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted Dec 08, 2025 - 07:13 EST

Identified

Due to a technical problem, some customers may be unable to download their invoices in the Control Panel.
Posted Dec 08, 2025 - 05:52 EST
This incident affected: Contract Management (Billing Service).