Incident Report for Customer Service Support Tool
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Nov 08, 2023 - 13:05 EST
Identified
Due to a technical issue with our Support Tools, our Customer Service Team may not be able to answer all questions related to your account.
Posted Nov 08, 2023 - 11:35 EST
This incident affected: Customer Service (Support Tool).