Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted 7 days ago. Jul 08, 2019 - 07:58 EDT
Update
Due to a technical disruption, recent purchases of products may be delayed during setup.
Posted 8 days ago. Jul 08, 2019 - 04:27 EDT
Update
We are continuing to work on a fix for this issue.
Posted 8 days ago. Jul 08, 2019 - 02:31 EDT
Identified
We are experiencing an issue with our Contract Tool. In urgent cases please contact Customer Care via 1-877-300-8316 to finalize the cancellation.

We are experiencing technical issues with placing orders.
Posted 8 days ago. Jul 08, 2019 - 02:01 EDT
This incident affected: Contract Management (Order Page, Cancellation Service).