Greater hold time in our Hotline

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted Jan 21, 2026 - 00:24 EST

Identified

Due to this technical disruption there may currently be an increased call volume to our hotlines. Waiting times may therefore be longer.
Posted Jan 20, 2026 - 23:57 EST
This incident affected: Customer Service (Customer Hotline).