Incident Report
Incident Report for ionos.com
Resolved
The systems are stable and all services are functioning normally again.
Posted 27 days ago. Apr 22, 2019 - 13:32 EDT
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted 27 days ago. Apr 22, 2019 - 12:12 EDT
This incident affected: Customer Service (Support Tool).