Disruption in logging into the Webmail
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Jan 14, 2020 - 12:09 EST
Identified
We have received reports that some of our customers may be experiencing issues when attempting to log into Webmail
Posted Jan 14, 2020 - 11:10 EST
This incident affected: Email (Webmail).