Incident Report for Mywebsite Now

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted Apr 02, 2023 - 04:01 EDT

Update

We have successfully minimized the disruption and are working to completely resolve it as soon as possible.
Posted Apr 02, 2023 - 03:48 EDT

Identified

Some customers may face issues while using their MyWebsite. We apologize for any inconvenience this may cause.
Posted Apr 02, 2023 - 03:37 EDT
This incident affected: Website Builder (MyWebsite NOW).