Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 15, 2023 - 16:31 EDT
Scheduled
Please be aware that we will be performing maintenance on our database systems.
The following services and functions may be unavailable:
- Updating customer data in the Control Panel and communication email for some Control Panel actions may not be sent out - Some customers may be unable to view their invoice in the Control Panel
Additionally, our Customer Service Team may not be able to answer all questions related to your account.
All systems will be available to you as usual when the maintenance is completed, however temporary downtime is possible.
We apologize for any inconvenience this may cause.
Posted Oct 13, 2023 - 12:13 EDT
This scheduled maintenance affected: Customer Service (Support Tool) and Contract Management (Billing Service).