Email address creation may not be possible
Incident Report for ionos.com
Resolved
The systems are stable and all services are functioning normally again.
Posted Jan 10, 2024 - 11:22 EST
Identified
Some customers may be experiencing issues creating email address
Posted Jan 10, 2024 - 10:07 EST
This incident affected: IONOS (IONOS Control Panel).