Incident Report for HiDrive
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Dec 26, 2023 - 16:16 EST
Identified
Some customers may be experiencing issues when accessing the HiDrive
Posted Dec 26, 2023 - 12:22 EST
This incident affected: Office (HiDrive).