Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Feb 19, 2020 - 07:42 EST
Identified
Due to a technical issue with our Support Tools, our Customer Service Team are not able to answer all questions related to your account.
Posted Feb 19, 2020 - 07:12 EST
This incident affected: Customer Service (Support Tool).