We are still working on resolving this issue. More information will follow soon.
Posted Jan 10, 2025 - 06:55 EST
Update
Our technicians are currently working on resolving this issue. Thank you for your patience and understanding.
Posted Jan 10, 2025 - 05:59 EST
Identified
Due to a technical issue, functionalities for sending emails (e.g. contact form) of our MyWebsite product may be unavailable. We apologize for any inconvenience caused.
Posted Jan 10, 2025 - 05:15 EST
This incident affected: Website Builder (MyWebsite NOW).