Incident Report for Customer Service Support Tool
Incident Report for ionos.com
Resolved
The systems are stable and all services are functioning normally again.
Posted Mar 02, 2022 - 10:09 EST
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted Mar 02, 2022 - 09:54 EST
This incident affected: Customer Service (Support Tool).