Incident Report for Duplicate Billing Charges
Incident Report for ionos.com
Resolved
The issue has been resolved for everyone affected. We thank you for your continued trust and support.
Posted Mar 22, 2024 - 10:15 EDT
Update
The fix has corrected the error for almost everyone affected. Thank you for your patience and understanding.
Posted Mar 21, 2024 - 01:52 EDT
Update
The resolution process is still ongoing, addressing the remaining affected customers. We are working tirelessly to ensure that all accounts are corrected promptly. Once again, we are very sorry for any inconvenience caused.
Posted Mar 18, 2024 - 09:44 EDT
Update
We have implemented a fix and are currently observing the effects. Our apologies for the inconvenience caused.
Posted Mar 15, 2024 - 07:38 EDT
Update
We are still working on resolving the technical issue. Thank you for your patience.
Posted Mar 13, 2024 - 05:34 EDT
Update
We are still working on resolving the technical issue. Rest assured that our system is actively addressing any instances of excessive or duplicate charges promptly. We apologize for the inconvenience caused and thank you for your patience.
Posted Mar 11, 2024 - 11:17 EDT
Identified
The issue has been identified and efforts are underway to implement a solution.
Posted Mar 11, 2024 - 09:11 EDT
Investigating
We are currently investigating reports of double billing charges affecting some of our customers.
Posted Mar 11, 2024 - 07:25 EDT
This incident affected: Contract Management (Billing Service).