Placing orders currently not possible
Incident Report for ionos.com
Resolved
This incident has been resolved.
Posted Oct 28, 2020 - 09:26 EDT
Identified
We are experiencing technical issues with placing orders on our Main Page https://www.ionos.com/.
Posted Oct 28, 2020 - 09:22 EDT
This incident affected: Contract Management (Order Page).